Can't install required libraries for SP on Ubuntu 22.

All other Source.Python topics and issues.
nesman
Junior Member
Posts: 4
Joined: Tue Jun 18, 2024 2:36 pm

Can't install required libraries for SP on Ubuntu 22.

Postby nesman » Tue Jun 18, 2024 2:44 pm

The wiki says I need libffi.so.6
http://wiki.sourcepython.com/general/installation.html

That is no longer found on ubuntu 22.

Code: Select all

apt-get install libffi6:i386
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package libffi6:i386


How do we install sourcepython?
cssbestrpg
Senior Member
Posts: 308
Joined: Sun May 17, 2020 7:56 am
Location: Finland
Contact:

Re: Can't install required libraries for SP on Ubuntu 22.

Postby cssbestrpg » Tue Jun 18, 2024 5:15 pm

I guess you could download this one i use.
It goes to server root folder(where is cstrike folder located for example) /bin
nesman
Junior Member
Posts: 4
Joined: Tue Jun 18, 2024 2:36 pm

Re: Can't install required libraries for SP on Ubuntu 22.

Postby nesman » Fri Jun 21, 2024 7:30 pm

That's certainly a solution. I think the file needs to be provided with the download if it's a requirement and can't be installed by apt anymore.
nesman
Junior Member
Posts: 4
Joined: Tue Jun 18, 2024 2:36 pm

Re: Can't install required libraries for SP on Ubuntu 22.

Postby nesman » Thu Jun 27, 2024 1:05 pm

Unfortunately this did not fix things. SP crashes the server on a fresh install. Shame.
cssbestrpg
Senior Member
Posts: 308
Joined: Sun May 17, 2020 7:56 am
Location: Finland
Contact:

Re: Can't install required libraries for SP on Ubuntu 22.

Postby cssbestrpg » Thu Jun 27, 2024 6:55 pm

which game?
nesman
Junior Member
Posts: 4
Joined: Tue Jun 18, 2024 2:36 pm

Re: Can't install required libraries for SP on Ubuntu 22.

Postby nesman » Wed Jul 10, 2024 5:21 pm

Team Fortress.
User avatar
Doldol
Senior Member
Posts: 201
Joined: Sat Jul 07, 2012 7:09 pm
Location: Belgium

Re: Can't install required libraries for SP on Ubuntu 22.

Postby Doldol » Sat Jul 13, 2024 8:04 am

Hello in case you're still looking I use this line in a docker container to fix dependencies for both the base server and SP, it may be outdated so if it doesn't outright work I hope it atleast points you in the right direction, the key is that your server isn't an x64 binary so you gotta get the 32bit libs

Code: Select all

dpkg --add-architecture i386 && apt-get update && DEBIAN_FRONTEND=noninteractive apt-get -y install libgcc-s1:i386 libstdc++6:i386 libtinfo5:i386 zlib1g zlib1g:i386 && curl -LO http://archive.ubuntu.com/ubuntu/pool/main/libf/libffi/libffi6_3.2.1-8_i386.deb && dpkg -i libffi6_3.2.1-8_i386.deb

Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 11 guests